Honda TRX ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I Had no spark on my250 X. I replaced the CDI from running atv, got spark.
However, with the swapped cdi , I do not get the green ignition lt when in Neutral. Put old cdi back in, I get the green lt. (no spark) same result with several CDIs. Took to a dealer and they said they were stumped. any help out there would be much appreciated. Thought I saw an add for after market cdi with dual circuitry. Are there some odd 250X atvs out there with dual ignition circuits in CDI? please help
 

·
Super Moderator
Joined
·
3,754 Posts
You do not have a TRX250X - the 250X was a kick start only and a neutral light was not necessary because there is no battery to power it and will start in gear as long as the clutch lever is pulled in. It did have a reverse light in the headlight shell, but it is a red light. Give me the VIN and I will tell you exactly what kind of TRX you have.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
250 x

Here 2 Help
Thank you for your response.
Fairly certain it is a 250X. I may have miss lead you with some of my info
It is kick start only. the lt is red, not green. Light labeled "Reverse". When you turn the engine over with the Kick starter, The red light comes on. (This always indicated to me that the Alternator was working). Also thought lt only came on in Neutral, as I have never been able to kick it over in anything but neutral. The light still works with the old CDI, but I have no spark. When I switch out the CDI, I get spark, but the light does not come on (ATV will not start either)
here is the info: Model trx 250X 10/86. fourtrax
Vin .. JH3TE1300HK003824
Eng NR .. TE13E-8003848

Once again thanks, any help is much appreciated.

rustttool
 

·
Super Moderator
Joined
·
3,754 Posts
It is in fact a 1987 TRX250X

The reverse light should only come on when the engine is running and the tranny is in reverse.

If you have spark and it won't start, then it might be; compression, spark timing, carb or something related to those items
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
The light has always come on while kick starting. It goes out once running and then only comes on when in reverse. acts like a typical alt light. The bike was running fine before I lost spark. When I put the old CDI back in I get the red light when I kick it over, but no spark. when I but the replacement CDI in I get spark, but no light. The lack of the red light would seem to me to indicate the alternator is not working, but there must be power to coil to get spark. hence my confusion. I do not have a schematic/wiring diagram, maybe I can get one off the web somewhere. My old CDI (a little smaller than the replacements), seemed to have 3 capacitors under the sealed plastic, whereas the replacements look like they only have two. there are no part numbers on the CDIs and the electrical connectors are all the same. Although they were supposedly off a working 87 250x, I have my doubts. In addition, even though the dealer was stumped in diagnosing the problem, one would think they would know the correct CDI. Does your red light come on when kick starting? I just assumed they all did.
Once again, thanks for getting back to me.
 

·
Super Moderator
Joined
·
3,754 Posts
No, the light only comes on when in reverse. If in reverse and holding the clutch in while kicking it will kinda blink. The CDI box you need is Honda part number 30410-HC0-003. It was only used on 87, 88, 91 and 92 TRX250X's. Honda did not produce the X in 89 or 90.
If you have spark the, the alternator is usually OK. The green wire off the alternator is ground. The white/yellow wire powers the electrical system and the black/red wire triggers the CDI to fire the coil. The black/white wire off the CDI unit goes to the kill switch. You kill the ignition by connecting the b/w wire to ground.

Check your PM for my email address. I can email you a wiring diagram.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks again for your response, However I must disagree. I do not want to offend you, as it is obvious you have a much greater knowledge of these bikes than I do. But the lt does come on when I kick it over with the old cdi installed, and has for the 10 plus yrs I have had the bike. The light gets brighter the harder I kick it (just like an alternator lt) The bike IS always in neutral when I try to start it (although I do use the clutch) I have never started it in any gear, including reverse. I have been working on this problem for over a year now, and I am getting frustrated with the bike and this problem. I have purchased several CDIs, and also sent the bike to a shop (dealer) for over a month with no luck. Logically, If I have spark, gas and the timing is right the bike should run. It doesn't even fire. Curious though, If I have been getting a lt, and should not. Maybe the previous owner(s) fiddled with the wiring. I did send you my email in a PM, as I would very much appreciate a wiring diagram. Once I receive it, I will trace everything out and see if the bike is wired according to specs. Thanks again for your time and patience.
 

·
Registered
Joined
·
2 Posts
I Had no spark on my250 X. I replaced the CDI from running atv, got spark.
However, with the swapped cdi , I do not get the green ignition lt when in Neutral. Put old cdi back in, I get the green lt. (no spark) same result with several CDIs. Took to a dealer and they said they were stumped. any help out there would be much appreciated. Thought I saw an add for after market cdi with dual circuitry. Are there some odd 250X atvs out there with dual ignition circuits in CDI? please help
 
1 - 10 of 10 Posts
Top