Honda TRX ATV Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all, I have a 1992 TRX300 that's been hit or miss with starting for a while. It has a new battery and a good plug, but it's not getting spark, so I ordered a new CDI. Just installed it and when trying to start up, it fires and almost starts, but then the reverse light immediately comes on and it stops trying to fire. I have to shift into and out of reverse for it to go off, and it comes back on once I try to start it again. I plugged the old cdi back in and there isnt any reverse light issue. And still no spark.
Is it the new cdi? It's slightly thicker and the plugs on it are in the center instead of off to the left side.
Or could it be a diode in line with the reverse switch, or the switch itself?

Any advice is greatly appreciated, as my patience with this thing is wearing thin.
 

·
Super Moderator
Joined
·
3,342 Posts
The diode is in the LH lever circuit so you can start it in gear. It allows the starter motor to spin in gear - when in neutral the starter spins without the lever being pulled in.

The position of the plug on the CDI is not important, but the reverse light coming is a concern. Unplug the grey wire on the reverse switch - if the reverse light still comes on, it's a bad or incorrect CDI unit.

Did you get an OEM CDI unit? Part number 30410-HC4-770 @ $151.25 or some Chinese 'fits' unit?

You would be better off with a used OEM instead of a Chinese 'looks like' unit. It has to be a DC unit - works off battery voltage.

Keep me posted
 
1 - 2 of 2 Posts
Top