Honda TRX ATV Forum banner
1 - 14 of 14 Posts

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi I am new and I have a 2008 Honda trx420fe with the electric shift. I have tested everything and I do have a manual book and it’s telling me it’s the pcm or the display. I have no power to fuel pump no spark and no power to shift motor. Everything else works except the gear indicator just blinks continuously. It turns over but won’t start and it will go threw the gears manually but won’t show a gear position. I have replaced fuel pump relay and position relay. Can anyone help please.
 

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #2 ·
Hi I have a trx420fe with electric shift and I have no spark no power to fuel pump and no power to shift motor. I have a Manuel and done a bunch of testing and it’s telling me it’s the pcm or a bad display. So I’m asking what do you all think. The gear indicator just blinks continuously and the neutral light is on and it turns over just fine but has no spark and no power to fuel pump or shift motor. I have put new fuel pump relay in and new position sensor but no luck. What should I do next. Should I replace the display and see if that works and if not I can return it and get a new pcm and try that. Please let me know of anything I’m missing or what you guys think.
 

·
Super Moderator
Joined
·
4,356 Posts
Welcome to the forum.

You have multiple problems that are unrelated to each other, but have a common power source so I would suspect a connection problem either ground or supply. You need to attack the lack of spark problem first

Do you have 12v on the blk/red wire at the coil?
 

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #5 ·
Welcome to the forum.

You have multiple problems that are unrelated to each other, but have a common power source so I would suspect a connection problem either ground or supply. You need to attack the lack of spark problem first

Do you have 12v on the blk/red wire at the coil?
Yes I have power to the red/black wire but no spark what does that mean?
 

·
Super Moderator
Joined
·
4,356 Posts
Yes I have power to the red/black wire but no spark what does that mean?
It means the PCM/ECM is not making ground on the grn/yel wire to create spark - either the pulse coil is not triggering the ECM or the ECM is faulty - need to check the peak voltage output of the pulse coil and all the ground connections.

Voltage on the red/blk wire means the fuse is good and the stop relay is closed - if there is 12v on the grn/yel wire at the ECM then the primary coil has continuity.
 

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #7 ·
It means the PCM/ECM is not making ground on the grn/yel wire to create spark - either the pulse coil is not triggering the ECM or the ECM is faulty - need to check the peak voltage output of the pulse coil and all the ground connections.

Voltage on the red/blk wire means the fuse is good and the stop relay is closed - if there is 12v on the grn/yel wire at the ECM then the primary coil has continuity.
I have checked all ground wires and checked the 3 ground wires on the ecm all was good I will check the green/yellow wire at the ecm tomorrow and let you know thanks for helping me and your fast response.
 

·
Super Moderator
Joined
·
4,356 Posts
I have checked all ground wires and checked the 3 ground wires on the ecm all was good I will check the green/yellow wire at the ecm tomorrow and let you know thanks for helping me and your fast response.
What progress have you made?
 

·
Registered
Joined
·
2 Posts
Hi I have a trx420fe with electric shift and I have no spark no power to fuel pump and no power to shift motor. I have a Manuel and done a bunch of testing and it’s telling me it’s the pcm or a bad display. So I’m asking what do you all think. The gear indicator just blinks continuously and the neutral light is on and it turns over just fine but has no spark and no power to fuel pump or shift motor. I have put new fuel pump relay in and new position sensor but no luck. What should I do next. Should I replace the display and see if that works and if not I can return it and get a new pcm and try that. Please let me know of anything I’m missing or what you guys think.
Go through & check ALL grounds including the 1 that holds rectifier to frame, then check battery. Sounds like electrical problem & ANY low voltage due to weak ground or low pos voltage will cause these problems. A weak battery will also cause these problems & corrosion in wires will also. Good luck
 

·
Registered
01 Honda 400EX
Joined
·
7 Posts
Hi I am new and I have a 2008 Honda trx420fe with the electric shift. I have tested everything and I do have a manual book and it’s telling me it’s the pcm or the display. I have no power to fuel pump no spark and no power to shift motor. Everything else works except the gear indicator just blinks continuously. It turns over but won’t start and it will go threw the gears manually but won’t show a gear position. I have replaced fuel pump relay and position relay. Can anyone help please.
de sounds electrical. Have to run codes if possible and go from there. I wouldn’t know where to start if not mechanical. So best you have a certified guy look at it. But it will be some plug or relay or senso.
 

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #11 ·
What progress have you made?
Go through & check ALL grounds including the 1 that holds rectifier to frame, then check battery. Sounds like electrical problem & ANY low voltage due to weak ground or low pos voltage will cause these problems. A weak battery will also cause these problems & corrosion in wires will also. Good luck
I have checked all grounds and battery is brand new and voltage checks out on battery. I have done all the steps in the manual and it says it’s the Cdi or the display. But it is weird for one of those to go out
 

·
Super Moderator
Joined
·
4,356 Posts
But it is weird for one of those to go out
No, just unfortunate - the CDI unit is part number 38770-HP5-603 @ $340 and the display is part number 37200-HP5-601 @ $195. The good news are they are still available from Honda.

That's why it's sometimes prudent to take it to a dealer for diagnosis even if you don't have them fix it, but if you take to a dealer, then they are responsible for fixing the problem if just plugging parts into doesn't fix it.

It is time consuming to check the voltages and continuity of every wire and connector, but it's usually necessary to be diligent and precise in diagnosing an electrical problem.

The more electronics are incorporated into simple mechanical devices the more expensive they become and the less user friendly they are. I have an electric scooter that was given to me because it quit working overnight - worked on day then nothing the next. The combination battery charger and motor controller failed during a charging period. The controller was $1800 and a new scooter was $2000.

Where are we going to dispose of all the electric vehicles that are scrapped? The batteries are full of toxic materials and they cannot be recycled like lead acid batteries. They have to be buried, burned or launched into oblivion to land on an uninhabited planet, asteroid or star (launch then into the sun) for disposal, but what happens when we run out of the rare earth materials to make the batteries. Oh well, that's not for my generation to worry about. My grandsons will be involved in that debacle.
 

·
Registered
2008 Trx420fe es
Joined
·
9 Posts
Discussion Starter · #14 ·
I will keep everyone posted on what I do and if I fix it or not and if you have any input please leave a message thanks
 
1 - 14 of 14 Posts
Top